当前位置:首页 > 问答

通达信kdj背离指标公式源代码

我来帮TA回答

求老师帮我编写一个kdj底部背离的选股公式

可以编写kdj底背离选股公式,但你说的15日内这个条件限制在哪比较模糊请说明白,如果仅仅是k值底背离,效果如下图。

求高手编一个通达信KDJ背离选股公式(有效再加400分!)

MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20);
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ;
DRAWICON((ZIG(3,5)=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2);

老师,请编写一个用于通达信的KDJ J值抬头和股价下跌背离的选股公式。

J交叉:=CROSS(KDJ.J,KDJ.K) AND CROSS(KDJ.K,KDJ.D);
{底背红买}
K值:="KDJ.K";
DD:=C=LLV(C,60);
DDSJ:=BARSLAST(REF(DD,1));{上一低点时间}
DDGJ:=REF(CLOSE,DDSJ+1)>CLOSE;
KDZB:=REF(K值,DDSJ+1)<K值;
K底背离:=DDGJ AND KDZB;
XG:J交叉 OR K底背离;

如果要二个条件同时成立,则用:
XG:J交叉 AND K底背离;

经测试,信号很小。

通达信 skdj底背离选股、预警公式(拜求专业指标编写,要求无未来函数)

这里应该没有人给你解决,建议去QQ群搜股票技术指标技术群,多加点,或许能找到

KDJ指标的使用技巧

1.K与D值永远介于0到100之间。D大于80时,行情呈现超买现象。D小于20时,行情呈现超卖现象。
2.上涨趋势中,K值小于D值,K线向上突破D线时,为买进信号。下跌趋势中,K值大于D值,K线向下跌破D线时,为卖出信号。
3.KD指标不仅能反映出市场的超买超卖程度,还能通过交叉突破发出买卖信号。
4.KD指标不适于发行量小、交易不活跃的股票,但是KD指标对大盘和热门大盘股有极高准确性。
5.当随机指标与股价出现背离时,一般为转势的信号。
6.K值和D值上升或者下跌的速度减弱,倾斜度趋于平缓是短期转势的预警信号。

如何灵活运用KDJ指标呢?

KDJ是随机指数没有很大的作用。要想在股票市场上有一点成绩,必须掌握MACD指标。这个是最实用的。最好学会看K线组合。这样就万无一失了。祝你成功。