底背驰选股公式,求老师帮我编写一个kdj底部背离的选股公式

Q1:求老师帮我编写一个kdj底部背离的选股公式

可以编写kdj底背离选股公式,但你说的15日内这个条件限制在哪比较模糊请说明白,如果仅仅是k值底背离,效果如下图。

Q2:谁能帮我编个macd底背离的选股公式,不盛感激!

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
DIFF:=SUM(MA1-MA2,0);
SUMMACD:=SUM(MACD,0);
W1:=BARSLAST(CROSS(MA2,MA1))+1;
W2:=BARSLAST(CROSS(MA1,MA2))+1;
W3:=BARSLAST(CROSS(MACD,0))+1;
W4:=BARSLAST(CROSS(-MACD,0))+1;

趋势力度:IF(K,SUMMACD-REF(SUMMACD,MIN(W3,W4)),DIFF-REF(DIFF,MIN(W1,W2)));
趋势平均力度:趋势力度/IF(K,(MIN(W3,W4)+1)/20,(MIN(W1,W2)+1)/20),COLORSTICK;
MAX趋势平均力度:HHV(趋势平均力度,34);
MIN趋势平均力度:LLV(趋势平均力度,34);
--------------------------------------------------------------------------------------------------------------------------------------------
K值可调,调成“0”是通过均线缠绕面积判断背驰
调成“1”是通过macd面积判断背驰。
白线为均线(或macd )到目前为止的面积,白线的拐点(即某一段的最大值(绝对值))是均线或macd面积。如果K调成1,红绿柱为凭据趋势力度。

此指标不是选股指标,是个副图指标,因为选股指标需要判断前后面积的大小,难度极大,不易做出,目前还没发现有人能写出来。

Q3:求通达信日线MACD底背离选股公式

A1:=BARSLAST(REF(CROSS(MACD.DIF,MACD.DEA),1));
MACD底背:REF(C,A1+1)>C AND REF(MACD.DIF,A1+1)<MACD.DIF AND CROSS(MACD.DIF,MACD.DEA);

(以前次金叉股价与现在金叉股价相比)

Q4:请写cci底背离选股公式

{N---自己定义取值;说明:该公式由于有BACKSET未来函数所以不具备实战价值}
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
RSI1:=CCI;
AA2:=REF(RSI1,N)=LLV(RSI1,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND RSI1=LLV(RSI1,N+1);
A2:=BARSLAST(REF(CC2,1));
底背离:REF(CLOSE,A2+1)>CLOSE AND REF(RSI1,A2+1)<RSI1 AND CC2;

Q5:macd博弈大师背离公式

面积2016平方千米。人口112万
县治新营市,辖2市7镇22乡:新营市、永康市;新化镇、麻豆镇、佳里镇、学甲镇、白河镇、盐水镇、善化镇;归仁乡、左镇乡、玉井乡、楠西乡、南化乡、仁德乡、关庙乡、龙崎乡、官田乡、西港乡、七股乡、将军乡、北门乡、后壁乡、东山乡、六甲乡、下营乡、柳营乡、大内乡、山上乡、新市乡、安定乡。

Q6:求MACD柱线与股价的背离,公式

MACD柱线与股价的背离,公式
DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA : EMA(DIFF,9);
MACD : 2*(DIFF-DEA), COLORSTICK,COLOR5454FF;
DD:=C=HHV(C,180);
EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;
CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;
上升背离:(CC AND EE)*DEA,COLOR00FFFF;
顶背离:(DD AND EE AND DEA< HHV(DEA,180))*DEA,STICK,LINETHICK3,COLORGREEN;
FF:=C=LLV(C,180);
GG:= DEA> REF(DEA,1) AND REF(DEA> REF(DEA,1),1)=1;
LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;
下降背离:(LL AND GG)*DEA,COLORMAGENTA;
底背离:(FF AND GG AND DEA> LLV(DEA,180))*DEA,STICK,LINETHICK3,COLORRED;
MM:=IF(MACD< 0,MACD,0);
JJ:=MM> REF(MM,1);
ZZ:=REF(JJ,1)=1;
介入区:(JJ AND ZZ)*DEA,POINTDOT,COLORRED;{MACD蓝柱缩短---指今日比昨天短}
STICKLINE(介入区=DEA,DEA,DIFF,3,0),COLORRED;
DRAWTEXT(CROSS(DIFF,DEA ),0,'金\N叉'),COLORCYAN;
DRAWTEXT(CROSS(DEA,DIFF ),0,'死叉'),COLORGREEN;